Summary:
1. Turn off ospf on all routers and configure basic IP addresses
2. Configure all routers to operate in a multiarea configuration.
-Tie, Belt, and Scok will act as ABRs
-Add 5 loopback interfaces to Ring, Hat, and Shoe to
simulate real ospf networks. They should be contiguous to
existing area subnets

1. Turn off ospf on all routers and configure basic IP addresses
Turn off ospf on all routers: no router ospf 1
Ring:
Ring#sh ip int br
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 unassigned YES unset administratively down down
FastEthernet0/1 unassigned YES unset administratively down down
Serial1/0 10.1.1.2 YES manual up up
Serial1/1 unassigned YES unset administratively down down
Serial1/2 unassigned YES unset administratively down down
Serial1/3 unassigned YES unset administratively down down
Ring#
Hat:
Hat#sh ip int br
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 unassigned YES unset administratively down down
FastEthernet0/1 unassigned YES unset administratively down down
Serial1/0 10.2.1.2 YES manual up up
Serial1/1 unassigned YES unset administratively down down
Serial1/2 unassigned YES unset administratively down down
Serial1/3 unassigned YES unset administratively down down
Belt:
Belt#sh ip int br
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 10.0.0.2 YES manual up up
FastEthernet0/1 unassigned YES unset administratively down down
Serial1/0 10.1.1.1 YES manual up up
Serial1/1 unassigned YES unset administratively down down
Serial1/2 unassigned YES unset administratively down down
Serial1/3 unassigned YES unset administratively down down
Loopback0 2.2.2.2 YES manual up up
Belt#
Tie:
Tie#sh ip int br
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 10.0.0.1 YES manual up up
FastEthernet0/1 unassigned YES unset administratively down down
Serial1/0 10.2.1.1 YES manual up up
Serial1/1 unassigned YES unset administratively down down
Serial1/2 unassigned YES unset administratively down down
Serial1/3 unassigned YES unset administratively down down
Loopback0 1.1.1.1 YES manual up up
Tie#
Sock:
Sock#sh ip int br
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 10.0.0.3 YES manual up up
FastEthernet0/1 unassigned YES unset administratively down down
Serial1/0 10.51.1.1 YES manual up up
Serial1/1 unassigned YES unset administratively down down
Serial1/2 unassigned YES unset administratively down down
Serial1/3 unassigned YES unset administratively down down
Loopback0 3.3.3.3 YES manual up up
Sock#
Shoe:
Shoe#sh ip int br
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 10.1.3.1 YES manual up up
FastEthernet0/1 unassigned YES unset administratively down down
Serial1/0 10.51.1.2 YES manual up up
Serial1/1 unassigned YES unset administratively down down
Serial1/2 unassigned YES unset administratively down down
Serial1/3 unassigned YES unset administratively down down
Loopback0 4.4.4.4 YES manual up up
Shoe#
2. Configure all routers to operate in a multiarea configuration.
-Tie, Belt, and Scok will act as ABRs
-Add 5 loopback interfaces to Ring, Hat, and Shoe to
simulate real ospf networks. They should be contiguous to
existing area subnets
Belt: (ABR)
router ospf 1
network 10.0.0.2 0.0.0.0 area 0
network 10.1.1.1 0.0.0.0 area 1
Ring:
router ospf 1
network 10.1.1.2 0.0.0.0 area 1
#Add 5 loopback interfaces to Ring
interface loopback0
ip address 10.1.0.1 255.255.255.0
ip ospf network point-to-point !----------- you fake GNS3 to see this as a real point to point, not loopback interface connection
interface loopback1
ip address 10.1.2.1 255.255.255.0
ip ospf network point-to-point
interface loopback2
ip address 10.1.3.1 255.255.255.0
ip ospf network point-to-point
interface loopback3
ip address 10.1.4.1 255.255.255.0
ip ospf network point-to-point
interface loopback4
ip address 10.1.5.1 255.255.255.0
ip ospf network point-to-point
#Advertise all loopback interfaces
router ospf 1
network 10.1.0.0 0.0.255.255 area 1
#Test:
Belt#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
2.0.0.0/32 is subnetted, 1 subnets
C 2.2.2.2 is directly connected, Loopback0
10.0.0.0/24 is subnetted, 7 subnets
O 10.1.3.0 [110/65] via 10.1.1.2, 00:00:56, Serial1/0
O 10.1.2.0 [110/65] via 10.1.1.2, 00:00:56, Serial1/0
C 10.1.1.0 is directly connected, Serial1/0
C 10.0.0.0 is directly connected, FastEthernet0/0
O 10.1.0.0 [110/65] via 10.1.1.2, 00:00:56, Serial1/0
O 10.1.5.0 [110/65] via 10.1.1.2, 00:00:56, Serial1/0
O 10.1.4.0 [110/65] via 10.1.1.2, 00:00:57, Serial1/0
Tie: (ABR)
router ospf 1
network 10.0.0.1 0.0.0.0 area 0
network 10.2.1.1 0.0.0.0 area 2
Hat:
router ospf 1
network 10.2.1.2 0.0.0.0 area 2
#Add 5 loopback interfaces to Hat
interface loopback0
ip address 10.2.0.1 255.255.255.0
ip ospf network point-to-point
interface loopback1
ip address 10.2.2.1 255.255.255.0
ip ospf network point-to-point
interface loopback2
ip address 10.2.3.1 255.255.255.0
ip ospf network point-to-point
interface loopback3
ip address 10.2.4.1 255.255.255.0
ip ospf network point-to-point
interface loopback4
ip address 10.2.5.1 255.255.255.0
ip ospf network point-to-point
#Advertise all loopback interfaces
router ospf 1
network 10.2.0.0 0.0.255.255 area 2
Sock: (ABR)
router ospf 1
network 10.0.0.3 0.0.0.0 area 0
network 10.51.1.1 0.0.0.0 area 51
Shoe:
router ospf 1
network 10.51.1.2 0.0.0.0 area 51
#Add 5 loopback interfaces to Shoe
interface loopback0
ip address 10.51.0.1 255.255.255.0
ip ospf network point-to-point
interface loopback1
ip address 10.51.2.1 255.255.255.0
ip ospf network point-to-point
interface loopback2
ip address 10.51.3.1 255.255.255.0
ip ospf network point-to-point
interface loopback3
ip address 10.51.4.1 255.255.255.0
ip ospf network point-to-point
interface loopback4
ip address 10.51.5.1 255.255.255.0
ip ospf network point-to-point
#Advertise all loopback interfaces
router ospf 1
network 10.51.0.0 0.0.255.255 area 51
-Yu